Add standard "Must be after no_chromium_code" comment in GN files.
[pdfium.git] / BUILD.gn
index 903e901..6accde5 100644 (file)
--- a/BUILD.gn
+++ b/BUILD.gn
@@ -554,8 +554,7 @@ static_library("fxge") {
   configs += [
     ":pdfium_config",
     "//build/config/compiler:no_chromium_code",
-    # As of this writing, this needs to be last to suppress a -Wswitch warning.
-    # https://crbug.com/547906
+    # Must be after no_chromium_code for warning flags to be ordered correctly.
     ":fxge_warnings",
   ]
 
@@ -757,7 +756,6 @@ test("pdfium_unittests") {
     "core/src/fxcrt/fx_basic_memmgr_unittest.cpp",
     "core/src/fxcrt/fx_basic_wstring_unittest.cpp",
     "core/src/fxcrt/fx_bidi_unittest.cpp",
-    "core/src/fxcrt/fx_extension_unittest.cpp",
     "core/src/fxcrt/fx_system_unittest.cpp",
     "third_party/base/nonstd_unique_ptr_unittest.cpp",
   ]